Back

Platform currently unavailable

January 5, 2026 at 08:00 PM CET Resolved after 44m

Updates

Resolved

The incident has been resolved. The platform is fully functional again.

January 5, 2026 at 08:44 PM CET
Investigating

We are currently experiencing an unexpected downtime.
Our team is working with highest priority to investigate this issue.

We will keep you updated on the progress of our investigation and provide an estimated time for when our services will be fully restored.

Thank you for your patience and understanding.

January 5, 2026 at 08:00 PM CET