Slow response times on EU Cloud
History
Resolved
December 16, 2024 8:49 AM CET
The incident has been resolved, and the platform is now fully operational again. We appreciate your patience and understanding.
Investigating
December 16, 2024 8:20 AM CET
We are currently investigating the issue.